Jayco Factory

(574) 825-5861

http://www.jayco.com/

903 S. Main Street
Middlebury, IN 46540

Jayco Factory is an RV Repair and Service center providing recreational vehicle support to the Middlebury, IN area.

RV Repair Direct requests that all past and present customers of this RV Repair Facility leave an honest and detailed review of the service they received. These reviews will help fellow RVers to make confident decisions on where to take their RV for repair in the geographic area of their choice. The reviews below are the opinions of RV Repair Direct readers, and do not reflect the endorsement or opinion of this website.

Services Offered

Facility Type

Payments Accepted

Discounts

Warranties

Certifications

Mobile Repair

No

5th Wheel Trailer

Posted: 2004-01-12 00:00:00

Generator would not give power to unit. Blowing circuit breakers when we plugged into 50 amp. Defects in the paneling. Frosted glass had a smear in the design. Shower and toilet leaked. Minor items, shower, toilet, glass smear repaired. Major items, generator not giving power to the unit? After 2 days we were called back to inspect the work. All interior lights were on and the generator was running. Factory authorized employees said 'See we have your generator working. We noticed the microwave and TV power indicator lights were not on and advised THEM that the lights they had on were powered by the battery. They had the generator working, but not powering the unit. We could do that. That was why we waited 6 months for the appointment. The 50 amp was blowing circuit breakers when we used 50 amp campgrounds? When we inquired if this was repaired and what they found we were told "WE DO NOT HAVE 50 AMP AT THE FACTORY. WHEN YOU PLUG INTO A 50 AMP SERVICE CALL BACK AND LET US KNOW HOW IT IS WORKING." When we plugged into a 50 amp service we had 220 volts down one wall and 60 down the opposite wall. We had an electrical fire. We lost all appliances. We paid for a washer/dryer that were burnt up less than a year after our RV purchase. Jayco removed them and has not returned them for over 9 months. They do not know what they are doing at the Factory. We were told 8/05 that the rep did not believe us when we told him they did not test the 50 amp at the Factory. He has ordered the parts now after finding this was a true statement and they will install 50 amp for situations such as ours.

Leave A Review

Your email address will not be published. Your review will be displayed after approval. All fields are required.